[Xotcl] about Object's cset....

Gustaf Neumann neumann at wu-wien.ac.at
Thu Dec 27 13:23:01 CET 2001

On Monday 24 December 2001 21:15, Andriy Tkachuk wrote:
> I've just tried an new (last) version of XOTcl and get an amount
> of my XOTcl code errors, that there isn't such function as cset!.
> In http://media.wu-wien.ac.at/doc/ChangeLog I saw:
> 2001-09-16 Uwe Zdun <uwe.zdun at uni-essen.de>
> ...
> - eliminated "cset" on Object and from the distribution, seems to
> 	  be nearly unused
> ...
> How did you estimate the unuseness!? :))
> On my mind, it was very usefull one,,, at last for me...

Well, here is the definition of cset.

Object instproc cset {vn arg} {
  if {![[self] exists $vn]} {
    [self] set $vn $arg

 we tried to keep the core definitions small,
 so it was dropped. sorry, if this hit you.

 there are recently some discussions about more
 powerful versions of set in the tcl community,
 so i expect something more general to appear sooner or
 later. so, if this tiny cset will be around in the
 xotcl-core, more and more applications will depend on
 it, and it should be made consistent with the more
 powerful set methods....

 A simple approach is to define a package named cset and import
 it via "package require", but somehow this seems
 like an overkill as well....

 what are the general opinions: 
  - add it again to the predefined set
  - add it as a separate package
  - do nothing (hope for better "set" methods)
  - others?

 any comments?


> thanks,
>   Andriy.
> _______________________________________________
> Xotcl mailing list  -  Xotcl at alice.wu-wien.ac.at
> http://alice.wu-wien.ac.at/mailman/listinfo/xotcl

More information about the Xotcl mailing list